<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if IE 7]><html class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--><html id="post-viewall" lang="en-US" class="no-js" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" data-is_mobilejs="false"><!--<![endif]-->
<head>

<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<title>Rihanna Loves This &#039;Honest&#039; Song She Wrote About Setting a Lover on Fire</title>
<script type='text/javascript'>cscd=new Object();cscd.partner='';cscd.template='';cscd.page_type='post';cscd.vertical='entertainment';cscd.analytic_vertical='Entertainment';cscd.vertical_ad='Entertainment';cscd.vertical_title='Entertainment';cscd.custom_ad='';cscd.wp_template='page.php';cscd.categories=["music"];cscd.json_tags=[];cscd.format='';cscd.show_ads='1';cscd.post_id=1529288;cscd.author='matthew-trzcinski';cscd.author_id=1635;cscd.subcategories=cscd.categories;cscd.focus_keyword='Rihanna';cscd.newsletters={"000":"list_Daily_Cheat_Sheet","005":"list_Entertainment"};cscd.article_template='paginated';cscd.page_number=1;cscd.tags=JSON.stringify(cscd.json_tags,',');cscd.yourls=[];cscd.workflow_analysis='';</script><script>(function () {var a={};var g=/iPhone/i,p=/iPod/i,i=/iPad/i,f=/\bAndroid(?:.+)Mobile\b/i,h=/Android/i,d=/(?:SD4930UR|\bSilk(?:.+)Mobile\b)/i,e=/Silk/i,c=/Windows Phone/i,j=/\bWindows(?:.+)ARM\b/i,k=/BlackBerry/i,l=/BB10/i,m=/Opera Mini/i,n=/\b(CriOS|Chrome)(?:.+)Mobile/i,o=/Mobile(?:.+)Firefox\b/i;function b($,a){return $.test(a)}function q($){var a=($=$||("undefined"!=typeof navigator?navigator.userAgent:"")).split("[FBAN");void 0!==a[1]&&($=a[0]),void 0!==(a=$.split("Twitter"))[1]&&($=a[0]);var r={apple:{phone:b(g,$)&&!b(c,$),ipod:b(p,$),tablet:!b(g,$)&&b(i,$)&&!b(c,$),device:(b(g,$)||b(p,$)||b(i,$))&&!b(c,$)},amazon:{phone:b(d,$),tablet:!b(d,$)&&b(e,$),device:b(d,$)||b(e,$)},android:{phone:!b(c,$)&&b(d,$)||!b(c,$)&&b(f,$),tablet:!b(c,$)&&!b(d,$)&&!b(f,$)&&(b(e,$)||b(h,$)),device:!b(c,$)&&(b(d,$)||b(e,$)||b(f,$)||b(h,$))||b(/\bokhttp\b/i,$)},windows:{phone:b(c,$),tablet:b(j,$),device:b(c,$)||b(j,$)},other:{blackberry:b(k,$),blackberry10:b(l,$),opera:b(m,$),firefox:b(o,$),chrome:b(n,$),device:b(k,$)||b(l,$)||b(m,$)||b(o,$)||b(n,$)},any:!1,phone:!1,tablet:!1};return r.any=r.apple.device||r.android.device||r.windows.device||r.other.device,r.phone=r.apple.phone||r.android.phone||r.windows.phone,r.tablet=r.apple.tablet||r.android.tablet||r.windows.tablet,r}a=q();if(typeof exports==="object"&&typeof module!=="undefined"){module.exports=a}else if(typeof define==="function"&&define.amd){define(function(){return a})}else{this["isMobile"]=a}})();</script><link rel="shortcut icon" type="image/x-icon" href="/favicon.ico?x80172">
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-57x57.png?x80172">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-60x60.png?x80172">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-72x72.png?x80172">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-76x76.png?x80172">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-114x114.png?x80172">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-120x120.png?x80172">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-144x144.png?x80172">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-152x152.png?x80172">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/apple-icon-180x180.png?x80172">
<link rel="icon" type="image/png" sizes="192x192"  href="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/images/icons/android-icon-192x192.png?x80172">

<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="ktiOxQqv9Xlcn7qytDrsOVw_-MQ9S7bo2G5Iyfu-I9M" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//feeds.feedburner.com/WallStCheatSheetCore" />
<link rel="pingback" href="https://www.cheatsheet.com/xmlrpc.php" />

<link href="https://plus.google.com/104665502628879394888" rel="publisher" />
<meta name="robots" content="NOODP,NOYDIR" />
<meta name="syndication-source" content="https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/" />
<meta name="p:domain_verify" content="936edf149ecbc3171d89b1f25f05e153" />

<!-- This site is optimized with the Yoast SEO Premium plugin v11.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Rihanna has given us pop hits of every variety. From rock ballads to dancehall jams to trap bangers, her discography is huge and eclectic. However,"/>
<link rel="canonical" href="https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rihanna Loves This &#039;Honest&#039; Song She Wrote About Setting a Lover on Fire" />
<meta property="og:description" content="Rihanna has given us pop hits of every variety. From rock ballads to dancehall jams to trap bangers, her discography is huge and eclectic. However," />
<meta property="og:url" content="https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/" />
<meta property="og:site_name" content="Showbiz Cheat Sheet" />
<meta property="article:publisher" content="https://www.facebook.com/ShowbizCheatsheet" />
<meta property="article:section" content="Entertainment" />
<meta property="article:published_time" content="2020-02-08T20:32:36+00:00" />
<meta property="article:modified_time" content="2020-02-08T20:32:45+00:00" />
<meta property="og:updated_time" content="2020-02-08T20:32:45+00:00" />
<meta property="og:image" content="https://www.cheatsheet.com/wp-content/uploads/2020/02/dark-lips-rihanna-1024x783.jpg" />
<meta property="og:image:secure_url" content="https://www.cheatsheet.com/wp-content/uploads/2020/02/dark-lips-rihanna-1024x783.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Rihanna has given us pop hits of every variety. From rock ballads to dancehall jams to trap bangers, her discography is huge and eclectic. However," />
<meta name="twitter:title" content="Rihanna Loves This &#039;Honest&#039; Song She Wrote About Setting a Lover on Fire" />
<meta name="twitter:site" content="@cheatsheet" />
<meta name="twitter:image" content="https://www.cheatsheet.com/wp-content/uploads/2020/02/dark-lips-rihanna-1024x783.jpg" />
<meta name="twitter:creator" content="@cheatsheet" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.cheatsheet.com/#organization","name":"Showbiz Cheat Sheet","url":"https://www.cheatsheet.com/","sameAs":["https://www.facebook.com/ShowbizCheatsheet","https://twitter.com/cheatsheet"],"logo":{"@type":"ImageObject","@id":"https://www.cheatsheet.com/#logo","url":"https://www.cheatsheet.com/wp-content/uploads/2019/05/scs-logo.png","width":295,"height":76,"caption":"Showbiz Cheat Sheet"},"image":{"@id":"https://www.cheatsheet.com/#logo"}},{"@type":"WebSite","@id":"https://www.cheatsheet.com/#website","url":"https://www.cheatsheet.com/","name":"Showbiz Cheat Sheet","publisher":{"@id":"https://www.cheatsheet.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.cheatsheet.com/search-results/?q={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#primaryimage","url":"https://www.cheatsheet.com/wp-content/uploads/2020/02/dark-lips-rihanna.jpg","width":1024,"height":783},{"@type":"WebPage","@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#webpage","url":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/","inLanguage":"en-US","name":"Rihanna Loves This &#039;Honest&#039; Song She Wrote About Setting a Lover on Fire","isPartOf":{"@id":"https://www.cheatsheet.com/#website"},"primaryImageOfPage":{"@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#primaryimage"},"datePublished":"2020-02-08T20:32:36+00:00","dateModified":"2020-02-08T20:32:45+00:00","description":"Rihanna has given us pop hits of every variety. From rock ballads to dancehall jams to trap bangers, her discography is huge and eclectic. However,"},{"@type":"Article","@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#article","isPartOf":{"@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#webpage"},"author":{"@id":"https://www.cheatsheet.com/#/schema/person/a3a83f4547916fc2267be79d96d4eee4"},"headline":"Rihanna Loves This &#8216;Honest&#8217; Song She Wrote About Setting a Lover on Fire","datePublished":"2020-02-08T20:32:36+00:00","dateModified":"2020-02-08T20:32:45+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#webpage"},"publisher":{"@id":"https://www.cheatsheet.com/#organization"},"image":{"@id":"https://www.cheatsheet.com/entertainment/rihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html/#primaryimage"},"articleSection":"Entertainment,Music"},{"@type":["Person"],"@id":"https://www.cheatsheet.com/#/schema/person/a3a83f4547916fc2267be79d96d4eee4","name":"Matthew Trzcinski","image":{"@type":"ImageObject","@id":"https://www.cheatsheet.com/#authorlogo","url":"https://www.cheatsheet.com/wp-content/uploads/2019/09/Matt-T-Avatar.jpg","caption":"Matthew Trzcinski"},"sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<meta property="fb:admins" content="826582091"/>
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.cheatsheet.com/wp-includes/css/dist/block-library/style.min.css?x80172' type='text/css' media='all' />
<style id='google-fonts-inline-css' type='text/css'>
@font-face{font-family:"PT Sans";font-style:italic;font-display:swap;font-weight:400;src:local("PT Sans Italic"),local("PTSans-Italic"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-italic.woff2") format("woff2"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-italic.woff") format("woff")}@font-face{font-family:"PT Sans";font-style:normal;font-display:swap;font-weight:700;src:local("PT Sans Bold"),local("PTSans-Bold"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-700.woff2") format("woff2"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-700.woff") format("woff")}@font-face{font-family:"PT Sans";font-style:italic;font-display:swap;font-weight:700;src:local("PT Sans Bold Italic"),local("PTSans-BoldItalic"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-700italic.woff2") format("woff2"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-700italic.woff") format("woff")}@font-face{font-family:"Montserrat";font-style:normal;font-display:swap;font-weight:400;src:local("Montserrat Regular"),local("Montserrat-Regular"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/montserrat-regular.woff2") format("woff2"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/montserrat-regular.woff") format("woff")}@font-face{font-family:"PT Sans";font-style:normal;font-display:swap;font-weight:400;src:local("PT Sans"),local("PTSans-Regular"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-regular.woff2") format("woff2"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/pt-sans-regular.woff") format("woff")}@font-face{font-family:"Montserrat";font-style:normal;font-display:swap;font-weight:700;src:local("Montserrat Bold"),local("Montserrat-Bold"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/montserrat-700.woff2") format("woff2"),url("/wp-content/themes/wallstcheatsheet-v2/css/google-fonts/montserrat-700.woff") format("woff")}

</style>
<link rel='stylesheet' id='site-style-css-css'  href='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/css/style.css?x80172' type='text/css' media='all' />
<link rel='stylesheet' id='print-css'  href='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/css/print.css?x80172' type='text/css' media='print' />
<script type='text/javascript' src='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/quantcast-choice.min.js?x80172' async='async'></script>
<script type='text/javascript' src='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/ads.js?x80172'></script>
<script type='text/javascript' src='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/vendor/prebid.js?x80172' async='async'></script>
<script type='text/javascript' src='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/cs-required.min.js?x80172'></script>
<link rel='https://api.w.org/' href='https://www.cheatsheet.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.cheatsheet.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.cheatsheet.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://www.cheatsheet.com/?p=1529288' />
<link rel="alternate" type="application/json+oembed" href="https://www.cheatsheet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cheatsheet.com%2Fentertainment%2Frihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cheatsheet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cheatsheet.com%2Fentertainment%2Frihanna-loves-this-honest-song-she-wrote-about-setting-a-lover-on-fire.html%2F&#038;format=xml" />
<script>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</script>
<script type='application/ld+json'>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</script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];

  PREBID_TIMEOUT = cs_pd.screen_width !== 'mobile' ? 1000 : 1500;

  googletag.cmd.push(function() {
    googletag.pubads().disableInitialLoad();
  });

  var stickL1Called = false;

  var initialAdUnit = [];
  initialAdUnit.push(adUnits[0]);

  pbjs.que.push(function() {
      pbjs.addAdUnits(initialAdUnit);
      pbjs.bidderSettings = {
        districtm: {
          bidCpmAdjustment : function(bidCpm) {
            return bidCpm * .85;
          }
        }
      };
      pbjs.aliasBidder('ix', 'indexExchange');
      pbjs.setConfig({
        priceGranularity: 'dense',
        bidderSequence: 'random',
        enableSendAllBids: false,          
      });
      pbjs.requestBids({
          bidsBackHandler: sendAdserverRequest
      });

      pbjs.onEvent('bidWon', function(event) {
          if (event.adUnitCode === 'div-cs-top1') {
              stickL1("div-cs-top1", event.height);
              stickL1Called = true;
          }
      });
  });

  function sendAdserverRequest() {
      if (pbjs.adserverRequestSent) return;
      pbjs.adserverRequestSent = true;
      googletag.cmd.push(function() {
          pbjs.que.push(function() {
              pbjs.setTargetingForGPTAsync(['div-cs-top1']);
              googletag.pubads().refresh([gptAdSlots['div-cs-top1']]);
          });
      });
  }

  setTimeout(function() {
      sendAdserverRequest();
  }, PREBID_TIMEOUT);
</script>

<script type='text/javascript'>
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script>
// GPT slots
var gptAdSlots = [];
var stpTop1 = cs_pd.screen_width !== 'mobile' ? '/8010089/WSCS_Testing_Leaderboard_1_728x90' : '/8010089/WSCS_Testing_Mobile_Leaderboard_1_320x50';

googletag.cmd.push(function() {

  /* Top 1 */
  gptAdSlots['div-cs-top1'] = googletag.defineSlot(cs_dfp.top1.ad, cs_dfp.top1.dimensions.concat(['fluid']), 'div-cs-top1').
  addService(googletag.pubads()).setTargeting('partner', cs_sd.partner).setTargeting('utm_term', cs_sd.utm_term).setTargeting('site', 'main');
  
  /*All DFP slots must be defined before this line */
  googletag.pubads().enableSingleRequest();

  /*
  * Slot Rendered
  */
  googletag.pubads().addEventListener('slotRenderEnded', function(event) {
    
    if (typeof event.slot !== "undefined" && event.slot === gptAdSlots['div-cs-top1'] && !stickL1Called) {
        stickL1("div-cs-top1", event.size[1]);
    }

    if (cs_dfp.top1.show === false) {
        document.body.style.paddingTop = 0;
        document.getElementById("sticky-top").style.display = 'none';
    }

  });

  googletag.enableServices();

  });

</script><style>.share--static{position:static!important;width:100%!important;opacity:1!important}.share--static .share__items{float:left!important;width:16.66%!important;padding:0 2px!important}.share--static .share__items--gplus{display:none!important}</style>

<!--[if lt IE 9]>
  <style>
    .last-child {
      margin-right: 0 !important;
    }
  </style>

  <script src="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/ie-built.min.js?x80172"></script>

 <![endif]-->

  <!-- Begin BounceX tag -->
  <script>
    if (csads.bouncex.show === true) {
		(function(d) {
			var e = d.createElement('script');
			e.src = d.location.protocol + '//tag.bounceexchange.com/'+csads.bouncex.id+'/i.js';
			e.async = true;
			d.getElementsByTagName("head")[0].appendChild(e);
		}(document));
    }
  </script>
  <!-- End BounceX tag -->

<script type="text/javascript">
window.NREUM||(NREUM={}),__nr_require=function(t,e,n){function r(n){if(!e[n]){var o=e[n]={exports:{}};t[n][0].call(o.exports,function(e){var o=t[n][1][e];return r(o||e)},o,o.exports)}return e[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(t,e,n){function r(){}function o(t,e,n){return function(){return i(t,[(new Date).getTime()].concat(u(arguments)),e?null:this,n),e?void 0:this}}var i=t("handle"),a=t(2),u=t(3),c=t("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","finished","addToTrace","inlineHit"],p="api-",l=p+"ixn-";a(s,function(t,e){f[e]=o(p+e,!0,"api")}),f.addPageAction=o(p+"addPageAction",!0),e.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(t,e){var n={},r=this,o="function"==typeof e;return i(l+"tracer",[Date.now(),t,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return e.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(t,e){d[e]=o(l+e)}),newrelic.noticeError=function(t){"string"==typeof t&&(t=new Error(t)),i("err",[t,(new Date).getTime()])}},{}],2:[function(t,e,n){function r(t,e){var n=[],r="",i=0;for(r in t)o.call(t,r)&&(n[i]=e(r,t[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;e.exports=r},{}],3:[function(t,e,n){function r(t,e,n){e||(e=0),"undefined"==typeof n&&(n=t?t.length:0);for(var r=-1,o=n-e||0,i=Array(o<0?0:o);++r<o;)i[r]=t[e+r];return i}e.exports=r},{}],ee:[function(t,e,n){function r(){}function o(t){function e(t){return t&&t instanceof r?t:t?u(t,a,i):i()}function n(n,r,o){t&&t(n,r,o);for(var i=e(o),a=l(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var s=f[m[n]];return s&&s.push([w,n,r,i]),i}function p(t,e){g[t]=l(t).concat(e)}function l(t){return g[t]||[]}function d(t){return s[t]=s[t]||o(n)}function v(t,e){c(t,function(t,n){e=e||"feature",m[n]=e,e in f||(f[e]=[])})}var g={},m={},w={on:p,emit:n,get:d,listeners:l,context:e,buffer:v};return w}function i(){return new r}var a="nr@context",u=t("gos"),c=t(2),f={},s={},p=e.exports=o();p.backlog=f},{}],gos:[function(t,e,n){function r(t,e,n){if(o.call(t,e))return t[e];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(t,e,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return t[e]=r,r}var o=Object.prototype.hasOwnProperty;e.exports=r},{}],handle:[function(t,e,n){function r(t,e,n,r){o.buffer([t],r),o.emit(t,e,n)}var o=t("ee").get("handle");e.exports=r,r.ee=o},{}],id:[function(t,e,n){function r(t){var e=typeof t;return!t||"object"!==e&&"function"!==e?-1:t===window?0:a(t,i,function(){return o++})}var o=1,i="nr@id",a=t("gos");e.exports=r},{}],loader:[function(t,e,n){function r(){if(!h++){var t=y.info=NREUM.info,e=s.getElementsByTagName("script")[0];if(t&&t.licenseKey&&t.applicationID&&e){c(m,function(e,n){t[e]||(t[e]=n)});var n="https"===g.split(":")[0]||t.sslForHttp;y.proto=n?"https://":"http://",u("mark",["onload",a()],null,"api");var r=s.createElement("script");r.src=y.proto+t.agent,e.parentNode.insertBefore(r,e)}}}function o(){"complete"===s.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=t("handle"),c=t(2),f=window,s=f.document,p="addEventListener",l="attachEvent",d=f.XMLHttpRequest,v=d&&d.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:d,REQ:f.Request,EV:f.Event,PR:f.Promise,MO:f.MutationObserver},t(1);var g=""+location,m={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-963.min.js"},w=d&&v&&v[p]&&!/CriOS/.test(navigator.userAgent),y=e.exports={offset:a(),origin:g,features:{},xhrWrappable:w};s[p]?(s[p]("DOMContentLoaded",i,!1),f[p]("load",r,!1)):(s[l]("onreadystatechange",o),f[l]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);
;NREUM.info={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",licenseKey:"d746a63cc4",applicationID:"3483790",sa:1}
</script>
<script>
if(cs_sd.partner == 'CMfacebook') {
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1447317708679797');
  fbq('track', 'PageView');
}
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=1447317708679797&ev=PageView&noscript=1"
/></noscript>

</head>

<body class="post-template-default single single-post postid-1529288 single-format-standard entertainment-theme cs-viewall">
<script>
var csHtmlTag = document.getElementsByTagName('html')[0];
dataLayer = [{
'category': 'entertainment',
'date_published': '2020-02-08 15:32:36',
'tags': cscd.tags,
'author': 'matthew-trzcinski',
'template': cs_sd.template,
'vertical_ad': cs_pd.vertical_ad,
'visitor_type': cs_ud.visitor_type,
'entrance_vertical': cs_sd.entrance_vertical,
'show_ads':cscd.show_ads,
'post_id':cscd.post_id,
'pageviews':cs_sd.pvs,
'subcategories':cscd.categories,
'partner': cs_sd.partner,
'utm_term': cs_sd.utm_term,
'utm_content': cs_sd.utm_content,
'screen_width': cs_pd.screen_width,
'analytic_vertical':cscd.analytic_vertical,
'workflow_analysis':cscd.workflow_analysis,
'content_source':cscd.content_source,
'prev_page_path': cs_sd.prev_page_path,
'article_view': document.getElementById("post-viewall") !== null ? 'spt' : 'paginated',
'ismobile.js': csHtmlTag.getAttribute("data-is_mobilejs") == 'true' ? csHtmlTag.getAttribute("data-device_type") : 'unknown'
}];
 </script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-532CLV"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-532CLV');</script>
<!-- End Google Tag Manager -->


<!-- Facebook SDK  -->
<div id="fb-root"></div>

<!--[if lt IE 8]>
	<p class="chromeframe">You are using an outdated browser. <a href="http://browsehappy.com/">Upgrade your browser today</a> or <a href="http://www.google.com/chromeframe/?redirect=true">install Google Chrome Frame</a> to better experience this site.</p>
<![endif]-->

<div id="wrapper">
    <div id="inner-wrapper">

        <div id="sticky-top" class="leader-board top-ad top-ad--sticky constraint constraint--lightbg">
        <div id="div-cs-top1" class="top1">
  <script type='text/javascript'>
	  if(cs_dfp.top1.show === true) {
	    googletag.cmd.push(function() {
	      googletag.display('div-cs-top1');
	    });
	  }
  </script>
</div>
    </div>
    
  <header id="navigation" class="site-header">
    <div class="site-header__row">
      <div class="constraint">        
        <a class="site-header__logo" href="https://www.cheatsheet.com/entertainment/"><span class="srt">Entertainment</span></a>        <div class="site-header__btns">
            <button type="button" class="btn btn--search"><i class="icon-search"></i></button>
            <button type="button" class="btn btn--menu"><i class="icon-menu"></i></button>
        </div>
      </div> <!-- constraint -->
    </div><!-- site-header__row -->

    <div class="site-header__row dark-bg">
      <div class="constraint">
        <div class="menu-container">
            <div class="site-header__nav">
                <nav class="nav-col">
                  <ul class="nav-list">
                    <li class="nav-list__item"><a class="gtm-home" href="https://www.cheatsheet.com/">Home</a></li>
                    <li class="nav-list__item"><a class="gtm-trending" href="https://www.cheatsheet.com/tag/trending/">Trending</a></li>
                    <li class="nav-list__item"><a class="gtm-celebrity" href="https://www.cheatsheet.com/celebrity/">Celebrity</a></li>
                    <li class="nav-list__item"><a class="gtm-movies" href="https://www.cheatsheet.com/category/movies/">Movies</a></li>
                    <li class="nav-list__item"><a class="gtm-tv" href="https://www.cheatsheet.com/category/tv/">TV</a></li>
                  </ul>
                </nav>           
                <nav class="nav-col">
                  <ul class="nav-list">
                    <li class="nav-list__item"><a class="gtm-royal-family" href="https://www.cheatsheet.com/royal-family/">Royal Family</a></li>
                    <li class="nav-list__item"><a class="gtm-net-worth" href="https://www.cheatsheet.com/net-worth/">Net Worth</a></li>
                    <li class="nav-list__item"><a class="gtm-music" href="https://www.cheatsheet.com/category/music/">Music</a></li>
                    <li class="nav-list__item"><a class="gtm-books" href="https://www.cheatsheet.com/category/books/">Books</a></li>
                  </ul>     
                </nav>
                <nav class="nav-col">
                  <ul class="nav-list nav-list--secondary">
                    <li class="nav-list__item nav-list__item--label"><span>More</span>
                      <span class="toggle-submenu hm-hide"><i class="icon-arrow"></i></span>
                      <ul class="subnav-list">
                          <li class="subnav-list__item"><a class="gtm-about" href="https://www.cheatsheet.com/about/">About Us</a></li>
                          <li class="subnav-list__item"><a class="gtm-archive" href="https://www.cheatsheet.com/archive/">Archive</a></li>
                          <li class="subnav-list__item"><a class="gtm-jobs" href="https://www.cheatsheet.com/jobs-2/">Jobs</a></li>
                          <li class="subnav-list__item"><a class="gtm-contact" href="https://www.cheatsheet.com/contact/">Contact Us</a></li>
                          <li class="subnav-list__item"><a class="gtm-terms-of-use" href="https://www.cheatsheet.com/terms-of-use/">Terms of Use</a></li>
                          <li class="subnav-list__item"><a class="gtm-privacy-policy" href="https://www.cheatsheet.com/privacy-policy/">Privacy Policy</a></li>
                      </ul>
                    </li>
                  </ul>
                </nav>    
                <nav class="nav-col">
                  <ul class="nav-list nav-list--secondary">
                    <li class="nav-list__item nav-list__item--label"><span>Our Sites</span>
                      <span class="toggle-submenu hm-hide"><i class="icon-arrow"></i></span>
                      <ul class="subnav-list">
                          <li class="subnav-list__item"><a target="_blank" href="https://www.remoter.co/">Remoter</a></li>
                          <li class="subnav-list__item"><a target="_blank" href="https://www.sportscasting.com/">Sportscasting</a></li>
                          <li class="subnav-list__item"><a target="_blank" href="https://www.motorbiscuit.com/">Motorbiscuit</a></li>
                      </ul>
                    </li>
                  </ul>
                </nav>                         
            </div><!-- site-header__nav -->
            <div class="site-header__nav site-header__nav--secondary">
                <div class="utilities">
                  <a class="social-facebook" href="https://www.facebook.com/ShowbizCheatSheet/" target="_blank"><i class="icon-facebook"></i><span class="srt">Facebook</span></a>
                  <a class="social-twitter" href="https://twitter.com/cheatsheet" target="_blank"><i class="icon-twitter"></i><span class="srt">Twitter</span></a>
                </div>   
                <div class="nav-copyright">2020 Showbiz Cheat Sheet,<br> All Rights Reserved.</div>
            </div><!-- site-header__nav--secondary -->
        </div>
      </div>
    </div><!-- site-header__row -->    

    <div class="site-header__row site-header__row--search">
      <div class="constraint">
        <div id="custom-search">
<gcse:searchbox-only resultsUrl="https://www.cheatsheet.com/search-results/"><div class="t-ac"><span class="spinner"></span></div></gcse:searchbox-only>
          <span class="close-searchbox"></span>
        </div>
      </div>
    </div><!-- site-header__row -->
  </header>
  <!-- CONTENT -->
  <div class="main-content constraint constraint--lightbg">
      <div class="content-fw content-fw--reset">
<div id="spt-app" ng-app="app">
  <div class="breadcrumb" vocab="http://schema.org/" typeof="BreadcrumbList"><span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" href="https://www.cheatsheet.com"><span property="name">Home</span></a><meta property="position" content="1"></span>  /  <span property="itemListElement" typeof="ListItem"><a property="item" typeof="WebPage" href="https://www.cheatsheet.com/entertainment/ "><span property="name">Entertainment</span></a><meta property="position" content="2"></span>  /</div>
  <article id="spt-initial-article" class="spt-alt-content">
    <div class="spt-alt-header">
      <h1 id="spt-initial-title">Rihanna Loves This &#8216;Honest&#8217; Song She Wrote About Setting a Lover on Fire</h1>
      <div class="byline">
          <div class="byline__info">
              <ul class="list-inline list-inline--author">
                  <li class="list-inline__item list-inline__item--bdr-right">
                      <a href="https://www.cheatsheet.com/author/matthew-trzcinski/" title="Posts by Matthew Trzcinski" rel="author">Matthew Trzcinski</a>
  
   

                  </li>
                  <li class="list-inline__item">
                      <a class="more-link" href="https://www.cheatsheet.com/music/">More <span class="hidden-sm">Articles</span></a>
                  </li>
              </ul>
              <br>
              <ul class="list-inline">
                  <li class="list-inline__item">
                    <div class="pubdate">February 08, 2020</div>
                  </li>
              </ul>
          </div>
      </div>   
    </div>
    <div class="spt-alt-content-body">
      <div id="spt-initial-content" class="spt-alt-content-entry">
        
<p>Rihanna has given us <a href="https://www.cheatsheet.com/entertainment/can-you-name-bruno-mars-5-biggest-hits.html/">pop hits</a> of every variety. From <a href="https://www.cheatsheet.com/entertainment/the-controversial-true-story-behind-george-harrisons-my-sweet-lord.html/">rock ballads</a> to dancehall jams to trap bangers, her discography is huge and eclectic. However, there’s one song she wishes she could have released as a single. Here’s what she had to say.</p>



<figure class="wp-block-image"><img id=dark-lips-rihanna-1024x783 data-cs_img_height="783" data-cs_img_width="1024"  src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://www.cheatsheet.com/wp-content/uploads/2020/02/dark-lips-rihanna-1024x783.jpg?x80172" alt="" class="wp-image-1529292"/><noscript><img id=dark-lips-rihanna-1024x783 src="https://www.cheatsheet.com/wp-content/uploads/2020/02/dark-lips-rihanna-1024x783.jpg?x80172" alt="" class="wp-image-1529292"/></noscript><figcaption>Rihanna attends the premiere <em>Oceans 8</em> | ANGELA WEISS/AFP via Getty Images</figcaption></figure>



<h2>One of Rihanna&#8217;s favorite Rihanna songs</h2>



<p>In an interview with <a target="_blank" href="https://www.glamour.com/story/rihanna-her-glamour-magazine-september-issue-cover-story">Glamour</a>, Logan Hill asked <a href="https://www.cheatsheet.com/entertainment/celebrity/rihannas-most-popular-songs.html/">Rihanna</a> which song she wishes was a single. Her answer was “Fire Bomb.&#8221; <a target="_blank" href="https://www.allmusic.com/album/rated-r-mw0001791113">AllMusic</a> says she co-wrote the track with James Fauntleroy and B. Kennedy Seals. The track features brutally honest lyrics about hating a lover. “I just wanna set you on fire/So I won&#8217;t have to burn alone/Then you/Then you&#8217;ll know where/I&#8217;m coming from/Fire bomb/Fire bomb.”</p>



<p>Rihanna told Glamour &#8220;’Fire Bomb’ is one of my favorite songs&#8230;It&#8217;s not the most positive message; it&#8217;s just honest. It&#8217;s about wanting revenge, because you just feel like no one can understand what you&#8217;re feeling unless you burn them the way they burned you. And that was at a time when I didn&#8217;t really want to be angry but I couldn&#8217;t help it, and ‘Fire Bomb’ was like that therapeutic song for me.&#8221;</p>



<p>Discussing lyrical honesty, Rihanna said “I think honesty is the ultimate liberation in life. People want to shy away from the truth and keep sweeping it under the rug. But after a while, you pick up the rug and there&#8217;s just way too much dirt, so you might as well just be up front about it. If you just face it today, then tomorrow you can move on to something else.”</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Fire Bomb" width="500" height="375" src="https://www.youtube.com/embed/rQyffNxYwKc?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div><figcaption>&#8220;Fire Bomb&#8221; by Rihanna</figcaption></figure>



<h2>Why Rihanna wants to be honest with her fans</h2>



<p>Rihanna likes being honest because it takes ammunition away from her critics. “ It just reminds me of <em>8 Mile</em>, when Eminem rapped every dis they could say about him. It gives you that freedom, because, what are they going to say about you now?</p>



<p><em>Rated R</em>, the album which features “Fire Bomb,” was a turning point in Rihanna’s music. “[The album] <em>Good Girl Gone Bad</em> was the first time I really took the reins in my career creatively. Then <em>Rated R</em> came right after that, and that&#8217;s when I realized, OK, my fans love the music; now I need to get a little deep with them, get a little more vulnerable, open up.”</p>



<p>She added &#8220;<em>Rated R</em> was the album that became really real, very honest. After that, it&#8217;s hard to go back to doing songs that are fiction. There was no coming back.&#8221;</p>



<h2>Did &#8216;Fire Bomb&#8217; work?</h2>



<figure class="wp-block-image"><img id=pink-rihanna-1024x736 data-cs_img_height="736" data-cs_img_width="1024"  src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://www.cheatsheet.com/wp-content/uploads/2020/02/pink-rihanna-1024x736.jpg?x80172" alt="" class="wp-image-1529295"/><noscript><img id=pink-rihanna-1024x736 src="https://www.cheatsheet.com/wp-content/uploads/2020/02/pink-rihanna-1024x736.jpg?x80172" alt="" class="wp-image-1529295"/></noscript><figcaption>Rihanna attending a Fenty Beauty Presentation | Angel Manzano/WireImage</figcaption></figure>



<p>Rihanna’s creative risk with “Fire Bomb” paid off. The <a target="_blank" href="https://latimesblogs.latimes.com/music_blog/2009/11/album-review-rihannas-rated-r.html">Los Angles Times</a> gave the track a rave review. The publication said “Fire Bomb” “puts Rihanna in a Molotov cocktail of a car&#8230;If these images read as corny, they&#8217;re made powerful by their settings, which also recall the classic melodrama of girl groups like the Shangri-Las, and by Rihanna&#8217;s singing, which powerfully invokes the internal conflict of a lover who knows what&#8217;s good for her but needs time to fully feel it.”</p>



<p>“Fire Bomb” wasn’t a hit. It wasn’t even a single. But for many Rihanna fans, it was an unforgettable artistic triumph.</p>



<p><strong><em>Also see:</em></strong> <strong><a href="https://www.cheatsheet.com/entertainment/rihanna-used-a-chris-brown-song-in-a-fenty-beauty-promo-and-fans-are-not-having-it.html/">Rihanna Used a Chris Brown Song in a Fenty Beauty Promo and Fans Are Not Having It</a></strong></p>
      </div>  
    </div>
  </article>

  <single-page-template></single-page-template>
  
  <base href="/">  
</div>
    </div>
    <!-- content-fw -->
</div>
<!-- main-content -->
<!-- /CONTENT -->

			<div class="leader-board constraint constraint--lightbg">
						</div>

			<div class="constraint constraint--lightbg" style="padding-bottom:5px; padding-top:5px;">
							</div>
<div id="stream-content-wrapper" class="constraint constraint--lightbg pb--baseline"><div class="stream-content stream-content--reco"></div></div>            <footer class="site-footer toggle-footer">
              <ul class="footer-nav">
                <li class="footer-nav__item copyright">2020 Showbiz Cheat Sheet, All Rights Reserved.</li>
                <li class="footer-nav__item"><a href="https://www.cheatsheet.com/about/">About Us</a>
                </li>
                <li class="footer-nav__item"><a href="https://www.cheatsheet.com/archive/">Archive</a>
                </li>
                <li class="footer-nav__item"><a href="https://www.cheatsheet.com/jobs/">Jobs</a>
                </li>
                <li class="footer-nav__item"><a href="https://www.cheatsheet.com/contact/">Contact Us</a></li>
                <li class="footer-nav__item"><a href="https://www.cheatsheet.com/terms-of-use/">Terms of Use</a>
                </li>
                <li class="footer-nav__item"><a href="https://www.cheatsheet.com/privacy-policy/">Privacy Policy</a></li>
              </ul>
            </footer>
          </div>
          <!-- .inner-wrapper -->
      </div>
      <!-- .wrapper -->

<script type="text/javascript" src="https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/vendor/jquery-3.3.1.min.js?x80172"></script>
<script type='text/javascript' src='https://www.cheatsheet.com/wp-content/plugins/single-page-template/frontend/dist/app.js?x80172'></script>
<script type='text/javascript' src='https://www.cheatsheet.com/wp-content/themes/wallstcheatsheet-v2/js/cs-all-built.min.js?x80172' async='async'></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js'></script>
<script type='text/javascript'>
(function(e,t){if(t._ym===void 0){t._ym=""; var m=e.createElement("script");m.type="text/javascript",m.async=!0,m.src="//static.yieldmo.com/ym.min.js",(e.getElementsByTagName("head")[0]||e.getElementsByTagName("body")[0]).appendChild(m)} else t._ym instanceof String||void 0===t._ym.chkPls||t._ym.chkPls()})(document,window);
</script>
<script type='text/javascript' src='https://www.cheatsheet.com/wp-includes/js/wp-embed.min.js?x80172'></script>

<script type="text/javascript">
  _bizo_data_partner_id = "4708";
</script>
<script type="text/javascript">
(function() {
  var s = document.getElementsByTagName("script")[0];
  var b = document.createElement("script");
  b.type = "text/javascript";
  b.async = true;
  b.src = (window.location.protocol === "https:" ? "https://sjs" : "http://js") + ".bizographics.com/insight.min.js";
  s.parentNode.insertBefore(b, s);
})();
</script>
<noscript>
  <img height="1" width="1" alt="" style="display:none;" src="//www.bizographics.com/collect/?pid=4708&fmt=gif" />
</noscript>
</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 0/0 objects using memcached
Page Caching using memcached 

Served from: www.cheatsheet.com @ 2020-02-08 21:13:51 by W3 Total Cache
-->